Incident with lucid.app
Incident Report for Lucid Software
Resolved
This incident has been resolved.
Posted Mar 13, 2023 - 11:07 MDT
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 13, 2023 - 11:00 MDT
Update
We are continuing to investigate this issue.
Posted Mar 13, 2023 - 10:51 MDT
Investigating
We are currently investigating this issue.
Posted Mar 13, 2023 - 10:33 MDT
This incident affected: US Region (Document List (US), Document Edit (US)).